Do not deploy Windows Management Framework 3.0 on servers running Exchange 2007 or Exchange 2010

Windows Management Framework 3.0Earlier this month Microsoft released Windows Management Framework 3.0 for Windows 2008 SP2, Windows 2008 R2 SP1 and Windows 7 SP1.

The update includes PowerShell 3.0, which is not currently compatible with Exchange 2007 or Exchange 2010.

The current advice from Microsoft is to not install this patch on systems running Exchange 2007 and Exchange 2010. This includes SBS 2008 and SBS 2011.

KB2506146 refers to Windows 2008 SP2

KB2506143 refers to Windows 2008 R2 SP1 and Windows 7 SP1

From the Exchange Team blog: http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx

Related Posts:

1. Exchange 2010 SP2 Rollup 5 v2 released

2. Exchange 2010 SP2 Rollup 5 unavailable due to issues it causes

3. Exchange 2010 SP2 Update Rollup 4 installation tips

0 thoughts on “Do not deploy Windows Management Framework 3.0 on servers running Exchange 2007 or Exchange 2010

  1. Luke H

    I saw this too. IMO they should embed some logic into the patch itself to prevent PowerShell 3.0 from appearing in the Windows Update list. Too easy for a tired admin to install by mistake and make a mess out of an Exchange installation. At the very least this should be in large bold letters all over the UR5-v2 KB page.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *